Author Topic: Password for public WiFi  (Read 36160 times)

Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Password for public WiFi
« on: July 20, 2012, 04:06:03 pm »
Hi,


I am running my router (fonera 2100) in node mode (with worldspot firmware) and want to set a password for the public wifi. Since there is no such option in the dashboard of the node setup I was wondering if there is a shell command that can be used to set a password?


Why password? The wifi data is transmitted unsecured and can be sniffed by everybody. If a hotspot user is entering password information on a webpage it might by catched and used to login unauthorized on that page.


Thanks for an answer.

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #1 on: July 20, 2012, 07:21:01 pm »
Hi

Usualy, hotspots are for public places, so there is no password.

You can set one by sending some commands through the dashboard (use multiple shell commands):
Code: [Select]
uci set wireless.@wifi-iface[0].key=wpahotspot
uci set wireless.@wifi-iface[0].encryption=psk
uci commit wireless
wifi

Or, you can also have both unencrypted + encrypted public SSIDs:
This is for adding a new encrypted public ssid:
(warning: the first command adds a newwifi which should be 2)
Code: [Select]
uci add wireless wifi-iface
uci set wireless.@wifi-iface[2].network=lan
uci set wireless.@wifi-iface[2].device=radio0
uci set wireless.@wifi-iface[2].mode=ap
uci set wireless.@wifi-iface[2].key=wpahotspot
uci set wireless.@wifi-iface[2].ssid=wpahotspot
uci set wireless.@wifi-iface[2].encryption=psk
uci commit wireless
wifi

Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #2 on: July 20, 2012, 10:14:03 pm »
Great thanks.
Will try this when the check-in works again. At the moment I have the same problem like Bibi: [size=78%]http://www.worldspot.net/forum/index.php/topic,4898.msg20858.html[/size]

Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #3 on: July 22, 2012, 11:25:37 am »
Solution if no more check-ins:

Add the other mac addresses that apear on the node set-up page. Then you get the check-ins again.

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #4 on: July 22, 2012, 11:29:40 am »
Could you please try the backfire version?

Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #5 on: July 22, 2012, 11:40:34 am »
I think I have already the backfire firmware:  www.worldspot.net/wk/Main/en/Accton
« Last Edit: July 22, 2012, 12:08:39 pm by Dotwin »

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #6 on: July 22, 2012, 09:21:54 pm »
The default firmware version comes from the trunk of openwrt, which is a "bleeding edge" version.
This is because some popular routers like latest tp-link routers are supported only by the trunk.

The more stable backfire branch should be fine for the foneras.

All worldspot firmware versions are here:
http://worldspot.net/wsfirm/


Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #7 on: July 23, 2012, 09:37:27 pm »
Thanks for the advise.
I tried backfire but no multi ssid and also only 5 mbps.
Seems that the fonera hardware is just too old.

What router would you recommend for buying that works well with worldspot firmware? TP-Link?
What about d-link routers?

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #8 on: July 23, 2012, 10:49:48 pm »

5mbs also with the private wifi?
strange you don't have mulissid with backfire...

tp-link are cheap and powerful (ar71xx based). But they don't have the flashing bootloader. I recommend them.


I don't know dlink. Openwrt compatibility must be checked before buying.


If you want higher end radios, look at ubiquity airmax m2 series.

Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #9 on: July 24, 2012, 05:13:13 pm »
Yes, only the pubic signal was visible.
Ok, will ook for a tp-link router then.

Thanks :)

Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #10 on: August 01, 2012, 08:33:01 pm »
I have a 
TP-LINK TL-WR1043ND now.
I guess on this page you only have the trunk versions:
http://www.worldspot.net/wk/Main/en/TpLink   right?
http://worldspot.net/wsf/ar71xx/openwrt-ar71xx-generic-tl-wr1043nd-v1-squashfs-factory.bin


So when I go here:
http://worldspot.net/wsfirm/backfire-r30950/ar71xx/


I will find the backfire version. Right? Maybe links on the webpage should be updated or choice between trunk and backfire should be given. Will save a lot of work and stops people asking questions like me now. ;)


Anyway my questions: What is the difference between openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin and [/size]openwrt-ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin


And how can I flash it now since I do not have access to web interface anymore? Because I installed the trunk version and I do not get a check-in.


Please help
Thanks

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #11 on: August 01, 2012, 10:51:35 pm »
Hi

I'm sorry to hear things went wrong.
The trunk version is supposed to work, as there are quite a number of wr1043 working. As it supports more recent hardware, it is the default choice.
You can always use the factory.bin version.
I suppose you have tried to reboot several times.

Can you please try to ssh to your router through the 10.150.1.1 ip address?
Instructions are given in the worldspot.net firmware page, in the trouble shooting section.

You can also try to boot in the "safe mode" by holding the button while powering the router on, but it will be more complicated to configure the internet and flash again.

Once connected, could you please try to copy paste the output of the "ifconfig" command?

You may also try the "firstboot" command

If all fails, you may reflash through the command line with the "sysupgrade -n flash-file"


Offline Dotwin

  • Sr. Member
  • ****
  • Posts: 54
Re: Password for public WiFi
« Reply #12 on: August 02, 2012, 11:41:17 pm »
Hi.


Thanks for the reply.


Unfortunately I cannot get a ssh connection with putty. Tried to set my lan settings to 10.150.1.2 and subnet 255.0.0.0 and gateway 10.150.1.1 but no success. Tired on both ports lan and wan port. I tried to change the subnet to 255.255.255.0 but also did not work. What can I do?


Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #13 on: August 05, 2012, 09:46:41 am »
hi sorry for late response.
Have you tried the fail safe method (with the button)?
Do you still have blank checkins?


Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2472
Re: Password for public WiFi
« Reply #14 on: August 16, 2012, 04:38:01 pm »
Hi


I was able to reproduce the problem with a wr1043.
The bug was identified, and a temporary workaround has been implemented.


Please plug your router again.