Author Topic: Extending your hotspot range  (Read 28970 times)

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #15 on: January 24, 2016, 06:43:31 pm »
Hello,
If I run worldspot firmware on a Picostation M2 connected by cable to the main DSL router, can I extend the coverage using repeater mode function in the ubiquiti firmware of a second Picostation M2 ?

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2435
Re: Extending your hotspot range
« Reply #16 on: January 24, 2016, 08:36:41 pm »
Hello

It is probable that it won't work.
However, you can use new wifi mesh feature of worldspot firmware to create a repeater.

You must follow the instructions in the new worldspot firmware doc.

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #17 on: January 25, 2016, 02:12:41 pm »
Hello,
Thanks...
1. Which firmware do I use on the Pico M2's to attempt the mesh feature ?
(I see 8 folders in Index of /wsbeta/barrier_breaker-r45841-4/........)

Should I select from "Mesh", or "Full Mesh" folder ?
I'm assuming I use a "sysupgrade" .bin file, but which one, "openwrt-ar71xx-generic-ubnt-bullet-m-squashfs-sysupgrade.bin"  3,4 MB ?

Lastly, do I use the same firmware on the base/dsl Pico and on the repeaters ?
and.....Has this been tested ?

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2435
Re: Extending your hotspot range
« Reply #18 on: January 25, 2016, 07:12:46 pm »
full means that the openwrt web interface is included. It is optionnal.
You can use mesh or full-mesh as you want. As you might not need the web interface, use the mesh version.

sysupgrade files are for upgrading from openwrt or worldspot firmware.
factory files are for upgrading from stock firmware.

I know that mesh feature is in production in one campground site with about 6 nodes mesh network, no known problem.
Please report if it works for you.

This feature uses batman-adv mesh network which is a very powerful feature.

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #19 on: January 26, 2016, 11:37:42 pm »
Putting the Pico M2 into tftp mode took around 10 or 12 seconds.
The transfer was fast, it took 11 seconds.
I left the Pico connected for 10 minutes then connected it to the Internet.
I set up the node but it didn't check in.
I remembered something about Ubiquiti Mac addresses needing to be modified.
In Luci (I'd flashed the full version), under Network/Interfaces/WAN, I noticed that the 8th character of the Mac address had been incremented by 1, so instead of a 2 there was a 3.
This was the only difference from the Mac address of the "Unknown device" reported on the Node setup page.
So I edited the Node Mac address and it checked in within a few seconds.
I used the root password in the WS documentation/troubleshooting section to access Luci.
So far so good..........
Question: Does a repeater node need to be added to the dashboard ?

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2435
Re: Extending your hotspot range
« Reply #20 on: January 26, 2016, 11:53:21 pm »
Yes the displayed mac address is often wrong.
You should use the one given in unknown node.

Yes, you should setup the repeater the same way, then disable coova-chilli using the commands given in the instructions.

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #21 on: January 27, 2016, 11:38:30 am »
1. The MAC given in "Unknown Node" didn't work until I incremented the 8th character from 2 to 3.

2. To add the repeater and configure it from the dashboard I will need to use more credits.
Are you willing to refund these, or offer them FOC ?

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2435
Re: Extending your hotspot range
« Reply #22 on: January 27, 2016, 11:57:56 am »
1. This is really strange. Are you talking about the subscripbtion mac address or the worldspot node mac address?
2. No you won't need another subscription as you disable coova-chilli in the repeater nodes. There is only one hotspot instance and your users will be able to roam between your wifi nodes.

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #23 on: January 27, 2016, 12:44:26 pm »
1.
The mac printed on the device was x8:xx:xx:x2:xx:xx.
The device didn't check in.

The unknown device mac reported xA:xx:xx:x2:xx:xx, so I used the edit button to change the mac to this.
Still no check in.

In the GUI I saw that the WAN interface was reported as x8:xx:xx:x3:xx:xx, so again I used the edit button to change the mac to this.
The device checked in.

2. How can I add the repeater to the dashboard without using credits ?
Are you suggesting that I use putty to disable coova-chilli and not add the repeater node to the dashboard ?

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2435
Re: Extending your hotspot range
« Reply #24 on: January 27, 2016, 12:46:49 pm »
2. You should register the node as usual.
no need for putty, you should use the dashboard to disable coova-chilli

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #25 on: January 27, 2016, 03:33:25 pm »
The repeater mac (The one printed on the device) needed similar modification to enable check-in.
Once again I increased the 8th character by one (again a 2, to a 3).
Now I'll send the shell commands.....

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #26 on: January 27, 2016, 04:13:54 pm »
Both devices, one wired to dsl, and one repeater not connected to dsl, are now checking in correctly.
Thanks for your help.

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #27 on: May 10, 2016, 04:32:30 pm »
What is the shell command to disable the chilli controller for a mesh repeater please ?
It used to be on the instructions page but I can no longer find it......

Offline WorldSpot

  • Administrator
  • Hero Member
  • *****
  • Posts: 2435
Re: Extending your hotspot range
« Reply #28 on: May 10, 2016, 05:10:22 pm »
the commands are:
echo DISABLE_CHILLI=yes > /etc/chilli/localConfig
/etc/init.d/chilli restart

this has been removed from the focumentation because there is a new command for this in latest worldspot firmware.

Does your mesh network work OK? I have very few feedback...

Offline wbrettw

  • Full Member
  • ***
  • Posts: 29
Re: Extending your hotspot range
« Reply #29 on: May 10, 2016, 05:23:47 pm »
Thanks for the fast reply.
OK I understand now, and yes, the mesh is working very well indeed.
I'm just adding two more repeaters to help cover the site which has many mobilehomes, some of which are clad with aluminium.


 

anything