WorldSpot.net forum

English forums => Bugs => Topic started by: electric on June 17, 2012, 07:52:04 pm

Title: "Bad supernode parameter" - Router log has many of this error
Post by: electric on June 17, 2012, 07:52:04 pm
Hello,
When I click on the "Display Logs" button in the "WorldSpot Firmware Realtime Dashboard" page, it shows this error every minute.  (ie: The log file is basically useless since it is just full of this repeating error...)
Is this a bug or a configuration issue?  Can it be fixed?
Quote
Jun 17 18:46:11 WRT54GL daemon.info n2n[1419]: Registering with supernode Jun 17 18:46:11 WRT54GL daemon.info n2n[1419]: WARNING: Bad supernode parameter (-l <host:port>) Jun 17 18:46:11 WRT54GL daemon.info n2n[1419]: Using supernode 217.172.xxx.xxx:8967 Jun 17 18:46:11 WRT54GL daemon.info n2n[1419]: Received REGISTER_ACK from remote peer [ip=217.172.xxx.xxx:8967]
Let me know...
Title: Re: "Bad supernode parameter" - Router log has many of this error
Post by: WorldSpot on June 17, 2012, 08:11:55 pm
Hi

This is a harmless message which has been removed in recent firmware.
If you want to get rid of it, you will have to reflash.
Title: Re: "Bad supernode parameter" - Router log has many of this error
Post by: electric on June 17, 2012, 10:10:28 pm
Ok, thanks.
Is there a changelog for new firmware versions?  I am wondering if there are perhaps any other features or fixes that would be beneficial to reflash...
Thanks!
Title: Re: "Bad supernode parameter" - Router log has many of this error
Post by: WorldSpot on June 17, 2012, 10:22:35 pm

New firmware version use a more recent version of openwrt trunk which supports some more hardware.This was the only fix.


Note that you could also try to update the "n2n" package from worldspot package dir (near the firmwares):
download with wget in /tmp
then install with opkg install (maybe with a reinstall option...)